In this method of “Web Filtering”, specific websites can be blocked on MikroTik using the Content Filter Rules. This filter can be found in the ‘Advanced’ tab while adding new firewall filter rules.
This method will try to match packets that contain the specified string in the URL, and then accordingly take an action on these packets as per what action is selected.
In order to block a website for e.g “Facebook” through a MikroTik, the steps are as follows:-
The MikroTik terminal command for adding the above rule is as follows:
/ip firewall filter add chain=forward protocol=tcp content="facebook" action=reject reject-with=icmp-host-unreachable comment="Block Facebook"
In Winbox, click on New Terminal. Copy and paste the above command in the terminal window and hit enter. The firewall rule as seen in the images above will be added instantly.
If there are multiple local networks created on the MikroTik router, the above rule created will block the website across all networks.
In order to block the website across only one network from among multiple networks created on MikroTik, we specify the network on which the website is to be blocked in the Src. Address field in the General tab while adding the Block Website rule, as seen in the image below:
The MikroTik terminal command for adding the above rule is as follows:
/ip firewall filter add chain=forward src-address="192.168.88.0/24" protocol=tcp content="facebook" action=reject reject-with=icmp-host-unreachable comment="Block Facebook"
The rule will thus block the website on all devices connected on the 192.168.88.0/24 network. In order to block the website only for a certain IP range, say the DHCP pool range, we specify the IP range in the Src Address field in the General tab while adding the Block Website rule, as seen in the image below:
The MikroTik terminal command for adding the above rule is as follows:
/ip firewall filter add chain=forward src-address="192.168.88.10-192.168.88.254" protocol=tcp content="facebook" action=reject reject-with=icmp-host-unreachable comment="Block Facebook"
The rule will thus block the website on all devices which are dynamically or manually assigned IP addresses in the range 192.168.88.10-192.168.88.254. The devices manually assigned IP addresses outside the DHCP pool will be able to access the website.
In order to block the website only for a certain device, there are two methods through which this can be done:
Method 1: We specify the static IP of the device in the Src. Address field in the General tab while adding the Block Website rule, as seen below:
The MikroTik terminal command for adding the above rule is as follows:
/ip firewall filter add chain=forward src-address="192.168.88.10" protocol=tcp content="facebook" action=reject reject-with=icmp-host-unreachable comment="Block Facebook"
The rule will block the website on only the device which is manually or dynamically assigned the IP address 192.168.88.10.
Method 2: We specify the MAC address of the device in the Src. MAC Address field in the Advanced tab while adding the Block Website rule, as seen below:
The MikroTik terminal command for adding the above rule is as follows:
/ip firewall filter add chain=forward src-mac-address="AA-BB-CC-DD-EE-FF" protocol=tcp content="facebook" action=reject reject-with=icmp-host-unreachable comment="Block Facebook"
The rule will block the website on only the device which has mac address of AA-BB-CC-DD-EE-FF.
If a website is blocked across all networks, or on a certain network, but certain specific devices need to be given access to these sites, then we will create another filter rule and place it above the existing Website Blocking rule. We recommend you read the below FAQ section in details.
How to Whitelist users (devices) to access blocked websites on Mikrotik
With multiple offices and partial team members working from homes, communicating becomes a challenge for both employees and employers as they will require..
Read MoreWhile the world is learning to adapt, albeit at a very sharp curve to accommodate remote working and Work from Home, I personally believe WFH sucks, not because there are..
Read MoreFor co-working spaces, internet downtime is a big NO-NO! A common issue we have observed is that ISPs promise a certain speed but in reality less than half that speed ..
Read More